Drivers













Driver Download Mirror #1
Scroll Down



Driver Requests




Post Your Driver Requests          Scan For Driver Updates
Scroll Down


Over 14,000 members strong!
Welcome to the Driver Request Forum

One of the very few, totally volunteer-supported device driver websites on the Internet. There are no gimmicks, or spyware traps just honest volunteers trying to help you find your drivers. Good luck!

Please read the instructions below.

ATTENTION: WE HAVE RECENTLY SUFFERED A DRIVER DATABASE CRASH.
IF YOU FIND A DEAD LINK TO A DRIVER PLEASE LET US KNOW SO WE CAN REPOST THE DRIVER ASAP.
THANK YOU.





Scroll Down to Post a Request
Search our Driver Request Forum



  • Scan For Driver Updates
  • Computer Support
  • Driver Download Mirror #1
  • Add This Website to Your Favorites List
  • Make This Site Your Homepage
  • View and Sign My Guestbook




  • CLICK HERE TO VIEW OUR SITE MAP
    Device Driver Request Post - Xp driver for hitachi external USB easy drive
    Device Driver Request Post
    Device Driver Request Post
    Home | Profile | Register | Active Topics | Members | Search | FAQ
    Username:
    Password:
    Save Password
    Forgot your Password?

     All Forums
     Driver Request Forums
     USB
     Xp driver for hitachi external USB easy drive
     New Topic  Reply to Topic
     Printer Friendly
    Author Previous Topic Topic Next Topic  

    smakawhat
    Starting Member

    2 Posts

    Posted - 10/15/2007 :  17:36:17  Show Profile  Reply with Quote
    Not sure if this the right place to post this but I'll give it a shot

    I purchased an external hitachi easy drive. here are more specs:

    * Manufacturer: Hitachi
    * Model Name: 500 GB Easy drive
    * Model Number: H3500U
    * Operating System: Windows XP home

    smakawhat
    Starting Member

    2 Posts

    Posted - 10/15/2007 :  17:39:41  Show Profile  Reply with Quote
    ok sorry about that I wasn''t finished giving info (post got sent).

    Anyway. I am running this on a Dell Dimension machine, and I have a 10 in 1 media card reader, and I also installed a firewire card myself.

    I only mention this cause it does not recognize my device. It searches for it, and it gets stuck under other devices. I am wondering if this is a device conflict, or if I have an outdated driver or something..

    I know the easy drive works cause I hooked it up to another machine running windows 2000 and it recognized it no problem.

    I called Hitachi and they can''t provide me any details... so if anyone has any idea what''s going on without me having to reinstall the OS... please let me know.

    Thanks,
    Go to Top of Page

    thegeek
    Forum Admin

    USA
    2165 Posts

    Posted - 10/16/2007 :  18:49:14  Show Profile  Reply with Quote
    Are you connecting via usb or firewire?

    If you are using front usb ports they are probably underpowered.

    If you are using firewire it could be an underpowered card (cheap?) or a bad card.

    DriverRequest.com''s Senior Driver Researcher

    Our service is totally free but our bandwidth
    costs are very high. Please help us keep
    this site alive by making a secure PayPal donation.
    Visit our donation page at
    http://www.driverrequest.com/donationpage.html
    Thank you for your support.
    Go to Top of Page
      Previous Topic Topic Next Topic  
     New Topic  Reply to Topic
     Printer Friendly
    Jump To:
    Device Driver Request Post © 2013 Home Computer Repair LLC Go To Top Of Page
    Powered By: Snitz Forums 2000 Version 3.4.07