Drivers













Driver Download Mirror #1
Scroll Down



Driver Requests




Post Your Driver Requests          Scan For Driver Updates
Scroll Down


Over 14,000 members strong!
Welcome to the Driver Request Forum

One of the very few, totally volunteer-supported device driver websites on the Internet. There are no gimmicks, or spyware traps just honest volunteers trying to help you find your drivers. Good luck!

Please read the instructions below.

ATTENTION: WE HAVE RECENTLY SUFFERED A DRIVER DATABASE CRASH.
IF YOU FIND A DEAD LINK TO A DRIVER PLEASE LET US KNOW SO WE CAN REPOST THE DRIVER ASAP.
THANK YOU.





Scroll Down to Post a Request
Search our Driver Request Forum



  • Scan For Driver Updates
  • Computer Support
  • Driver Download Mirror #1
  • Add This Website to Your Favorites List
  • Make This Site Your Homepage
  • View and Sign My Guestbook




  • CLICK HERE TO VIEW OUR SITE MAP
    Device Driver Request Post - lol..omg i'm lost
    Device Driver Request Post
    Device Driver Request Post
    Home | Profile | Register | Active Topics | Members | Search | FAQ
    Username:
    Password:
    Save Password
    Forgot your Password?

     All Forums
     Driver Request Forums
     Network Adapters
     lol..omg i'm lost
     New Topic  Reply to Topic
     Printer Friendly
    Author Previous Topic Topic Next Topic  

    miahmonster99
    Starting Member

    1 Posts

    Posted - 12/13/2005 :  19:16:40  Show Profile  Send miahmonster99 a Yahoo! Message  Reply with Quote
    hi, i recently ..reinstalled windows xp, i have a sony viao desktop pcv-rs620g,i have xp pro version 5.1 service pack 2, build 2600, well after i installed the pc works fine..except i can not establish an internet connection, i have run the wizard a million..well..a hundred times, after many hours of searching..it took hours..because i don't know ANYTHING,I stumbled across device manager...at other devices there are big yellow question marks...and when i go into properties..it says there are no drivers for 1.ethernet controller 2.multimedia audio controller 3. multimedia video controller 4. pci modem...i have had this same pc in my room for 6 months..hooked up to the same router, i have never had a problem until the xp pro install...i had xp home prior...i just don't want to start downloading the wrong drivers and mess things up more..so HELP ME!!...please:)

    thegeek
    Forum Admin

    USA
    2165 Posts

    Posted - 12/14/2005 :  08:13:23  Show Profile  Reply with Quote
    This is the driver page for your laptop. Download the drivers for each device you need and burn them to a cd from another computer to install on your laptop.
    http://esupport.sony.com/perl/model-swu.pl?mdl=PCVRS620G&LOC=3

    DriverRequest.com''s Senior Driver Researcher

    Our service is totally free but our bandwidth
    costs are very high. Please help us keep
    this site alive by making a secure PayPal donation.
    Visit our donation page at
    http://www.driverrequest.com/donationpage.html
    Thank you for your support.
    Go to Top of Page
      Previous Topic Topic Next Topic  
     New Topic  Reply to Topic
     Printer Friendly
    Jump To:
    Device Driver Request Post © 2013 Home Computer Repair LLC Go To Top Of Page
    Powered By: Snitz Forums 2000 Version 3.4.07